MyStudentInfo Outage

Resolved

This incident has been resolved.
Posted Jul 08, 2025 - 08:19 ACST

Update

Service Restored
Posted Jul 08, 2025 - 08:12 ACST

Update

Service Restored
Posted Jul 08, 2025 - 08:11 ACST

Investigating

We are currently investigating this issue.
Posted Jul 07, 2025 - 18:06 ACST
This incident affected: Callista (MyStudentInfo).